Quantcast
Channel: CodeSection,代码区,网络安全 - CodeSec
Viewing all articles
Browse latest Browse all 12749

安全更新(DSA-3608-1 &DSA-3609-1 &DSA-3611-1 &DSA-3613-1 &am ...

0
0

安全更新(DSA-3608-1 &DSA-3609-1 &DSA-3611-1 &DSA-3613-1 &am ...

此次安全漏洞更新包括libreoffice、tomcat8、libcommons-fileupload-java、libvirt、tomcat7、wireshark、horizon、libgd2、pidgin、squid3、openssh、phpmyadmin、ntp、libgd2、php5、mariadb-10.0及collctd更新。

漏洞概述

DSA-3608-1 libreoffice ― 安全更新

安全数据库详细信息:

在libreoffice中的RTF解析器中发现一个未对输入进行检查的缺陷,若一个畸形的文档被打开的话,能够执行任意代码。

DSA-3609-1 tomcat8 ― 安全更新

安全数据库详细信息:

多个安全威胁问题在Tomcat servlet和JSP引擎中被发现,这些问题可能信息的泄漏、绕过CSRF保护机制,绕过安全管理或造成拒绝服务。

DSA-3611-1 libcommons-fileupload-java ― 安全更新

安全数据库详细信息:

在Apache通用文件装载(可以容易地添加稳健、高性能、文件上装载能力到servlets和web应用中的包)中发现一个拒绝服务的威胁。远程攻击者可以利用此缺陷发送文件装载请求致使用了此库的http服务器变得反应迟钝,使服务器不再能够对其它的请求进行回应。

DSA-3613-1 libvirt ― 安全更新

安全数据库详细信息:

在Libvirt中设置一个空的VNC密码,不能够正常工作的问题。当在一个VNC服务器上设置密码为空字符串时,VNC服务器上的身份验证将被禁用,允许任何用户连接,尽管文件中宣称VNC服务器设置空密码时将阻止所有客户端连接。

DSA-3614-1 tomcat7 ― 安全更新

安全数据库详细信息:

在Apache通用文件加载时发现一个拒绝服务的问题。远程攻击者能够利用此漏洞发送装载请求至使用发此库的http服务器,使服务器变得迟钝,使服务器服务于其他请求。

DSA-3615-1 wireshark ― 安全更新

安全数据库详细信息:

多个漏洞在PKTC, IAX2, GSM CBCH and NCP, SPOOLS, IEEE 802.11, UMTS FP, USB, Toshiba, CoSine, NetScreen, WBXML的解析器中发现,这些漏洞可能导致拒绝服务或潜在的任意代码执行。

DSA-3617-1 horizon ― 安全更新

安全数据库详细信息:

在Horizon(控制OpenStack云的一个web应用)中发现两个跨站脚本漏洞。

DSA-3619-1 libgd2 ― 安全更新

安全数据库详细信息:

在libgd2库中发现多个漏洞。远程攻击者可以利用这些漏洞造成使用了此库的应用程序发生拒绝服务,或可能使用使用了此库的应用程序的权限执行任意代码。

DSA-3620-1 pidgin ― 安全更新

安全数据库详细信息:

在pidgin(支持多协议的即时通讯客户端)中发现多个漏洞。远程攻击者能够使用这些漏洞造成拒绝服务(程序崩溃),覆盖文件,信息泄漏,或执行任意代码。

DSA-3625-1 squid3 ― 安全更新

安全数据库详细信息,在Squid缓存代理软件中发现几个安全问题:

CVE-2016-4051:当处理通过Squid提供的输入时,在cachemgr.cgi中发现一个缓冲区溢出的漏洞; CVE-2016-4052:当处理ESI回应时存在一个缓冲区溢出的漏洞,此漏洞会造成拒绝服务的攻击; CVE-2016-4053:当处理ESI回应时发现一个服务堆栈布局的公共信息泄漏的漏洞; CVE-2016-4054:当处理ESI回应时发现Squid可以远程执行代码的漏洞; CVE-2016-4554:Squid头伪造后造成在Squid和一些客户端浏览器中绕过原始的安全策略。 CVE-2016-4555, CVE-2016-4556:在处理ESI回应时由于不正确地指针处理及参考计数,存在拒绝服务的攻击。

DSA-3626-1 openssh ― 安全更新

安全数据库详细信息:

OpenSSH SSH守护服务允许用户用过枚举时间性差异时,试图验证用户身份。当sshd尝试验证一个不存在的用户时,它会使用一个使用了Blowfish算法的哈希值去写一个假的密码结构。如果真实的用户的密码使用的是SHA256/SHA512,那么远程攻击者可以利用此漏洞发送大量的密码,接收更短的服务的回应时间。

DSA-3627-1 phpmyadmin ― 安全更新

安全数据库详细信息:在phpMyAdmin(基于web的mysql管理界面)中发现多个漏洞。

CVE-2016-1927:suggestPassword方法信赖的不安全的随机数生成器生成简单,这将为远程攻击者进行密码的猜测更加容易; CVE-2016-2039:CSRF令牌值是通过不安全的随机数生成器生成的,远程攻击者将能够绕过权限限制。 CVE-2016-2040:多个跨站漏洞允许远程认证用户注入任意的web脚本或HTML语句。 CVE-2016-2041:phpMyAdmin不使用常量时间算法来比较CSRF令牌,这使得远程攻击者更容易通过测量时间差来绕过预期的访问限制。 CVE-2016-2560:多个跨站漏洞允许远程攻击者能够注入任意的web脚本或html语句。 CVE-2016-2561:多个跨站漏洞允许远程攻击者注入任意的web脚本或HTML语句。 CVE-2016-5099:多个跨站漏洞允许远程攻击者注入任意的web脚本或HTML语句。 CVE-2016-5701:有关普通http运行安装,phpMyAdmin允许远程攻击者通过URI进行对HTTP会话BBCode的注入攻击。 CVE-2016-5705:多个跨站漏洞允许远程攻击者注入任意的web脚本或HTML语句。 CVE-2016-5706:phpMyAdmin允许远程攻击者通过在脚本参数使用大数组造成拒绝服务(资源耗尽)。 CVE-2016-5731:多个跨站漏洞允许远程攻击者注入任意的web脚本或HTML语句。 CVE-2016-5733:多个跨站漏洞允许远程攻击者注入任意的web脚本或HTML语句。 CVE-2016-5739:特殊伪造的转换可能泄漏信息,远程攻击者可以利用去执行跨站请求伪造信息。

DSA-3629-1 ntp ― 安全更新

安全数据库详细信息,在ntp网络时间协议守护程序中发现几个安全问题:

CVE-2015-7974:密钥验证不足造成用户间的假冒攻击漏洞; CVE-2015-7977/CVE-2015-7978:空指针引用、在处理ntpdc reslist命令时的缓冲区溢出的漏洞,可以导致服务的拒绝。 CVE-2015-7979:如果NTP配置为广播模式,攻击者能够发送畸形的与服务打破关联的验证包给其它广播客户端。 CVE-2015-8138:在ntpd客户端中原始时间戳未验证合法性,这可能造成服务拒绝; CVE-2015-8158:对输入缺少合理检查,可能导致拒绝服务; CVE-2016-1547:NAK包的加密的不正确处理,可导致拒绝服务; CVE-2016-1548:ntp客户端可能强制修改基本的客户端/服务器模式为交错对称模式,阻止时间同步的漏洞; CVE-2016-1550:在包验证代码中的时间漏洞,能导致消息摘要的恢复; CVE-2016-2516:在unconfig指令中重复的IP将触发断言; CVE-2016-2518:OOB内存访问可能导致ntpd的崩溃。

DSA-3630-1 libgd2 ― 安全更新

安全数据库详细信息:

在libgd2(图形创建、操作的库)中的_gdContributionsAlloc()方法中发现一个整数溢出的漏洞。远程攻击者可以利用此漏洞导致使用了此库的应用程序服务的拒绝。

DSA-3631-1 php5 ― 安全更新

安全数据库详细信息:

在PHP中发现多个漏洞。这些漏洞已经在上游最新版本中进行了修复,关于详细信息请参看:https://php.net/ChangeLog-5.php#5.6.24

DSA-3632-1 mariadb-10.0 ― 安全更新

在mariadb数据库服务发现几个安全问题,这些问题已经在mariadb的上游最新版本10.0.26中进行了修复。关于最新版本的详情请参看:

https://mariadb.com/kb/en/mariadb/mariadb-10026-release-notes/

DSA-3636-1 collectd ― 安全更新

在collctd(统计数据收集和监控的守护程序)中发现对于来自网络的数据包没有正确处理。这导致堆溢出,允许远程攻击者通过应用程序崩溃导致拒绝服务或执行任意代码。

修复情况

libreoffice的安全漏洞在1:5.1.4~rc1-1版本中进行了修复;tomcat8的安全漏洞在8.0.36-1版本中进行了修复;libcommons-fileupload-java 的安全漏洞在1.3.2-2以上版本中进行了修复,libvirt的安全漏洞在2.0.0-1以上版本中进行了修复,tomcat7的安全漏洞在7.0.70-1以上版本中进行了修复,wireshark的安全漏洞在2.0.4+gdd7746e-1以上版本中进行了修复,horizon的安全漏洞在3:9.0.1-2以上版本中进行了修复,libgd2的安全漏洞在2.2.2-29-g3c2b605-1以上版本中进行了修复,pidgin的安全漏洞在2.11.0-1以上版本中进行了修复,squid3的安全漏洞在3.5.19-1以上版本中进行了修复,openssh的安全漏洞在1:7.2p2-8以上版本中进行了修复,phpmyadmin的安全漏洞在4:4.6.3-1以上版本中进行了修复,ntp的安全漏洞在1:4.2.8p7+dfsg-1以上版本中进行了修复,libgd2的安全漏洞在2.2.2-43-g22cba39-1以上版本中进行了修复,php5的安全漏洞在7.0.9-1以上版本中进行了修复,mariadb-10.0的安全漏洞在10.0.26-2以上版本中进行了修复,collctd的安全漏洞在5.5.2-1以上版本中进行了修复。

请各位尽快更新系统以获取漏洞修复补丁。

Follow Us:Website|Forum

Weibo| Twitter | Facebook | IRC | Distrowatch

Viewing all articles
Browse latest Browse all 12749

Latest Images

Trending Articles





Latest Images