Quantcast
Channel: CodeSection,代码区,网络安全 - CodeSec
Viewing all articles
Browse latest Browse all 12749

GnuTLS gnutls_ocsp_resp_check_crt安全机制绕过漏洞(CVE-2016-7444)

0
0

GnuTLS gnutls_ocsp_resp_check_crt安全机制绕过漏洞(CVE-2016-7444)

发布日期:2016-09-28

更新日期:2016-09-28

受影响系统:

GnuTLS GnuTLS < 3.4.15

描述:

CVE(CAN) ID: CVE-2016-7444

GnuTLS是SSL、TLS和DTLS的开源实现,用APIs、X.509、PKCS #12、OpenPGP和其他安全数据类型进行网络通信加密。

GnuTLS < 3.4.15、3.5.x < 3.5.4版本,lib/x509/ocsp.c/gnutls_ocsp_resp_check_crt函数未验证OCSP响应的序列长度,远程攻击者利用此漏洞可绕过目标证书验证机制。

<*来源:Stefan Bühler

*>

建议:

厂商补丁:

GnuTLS

------

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://gitlab.com/gnutls/gnutls/commit/964632f37dfdfb914ebc5e49db4fa29af35b1de9

https://www.gnutls.org/security.html

本文永久更新链接地址 : http://www.linuxidc.com/Linux/2016-09/135602.htm


Viewing all articles
Browse latest Browse all 12749